Page 1 of 1

Editing posts, quoting and other forum-related questions

Posted: Sat Sep 26, 2015 5:43 pm
by erundil
I'm a relatively new to this forum, so hello everyone!

Since I'm new I have some questions about the forum itself. I can't find a dedicated topic (or even subforum) for this kind of questions, so here's a new topic.

1. How do I edit my posts? All I can see is a "delete" button. Will I unlock this option at a certain post count or something?
2. How do I quote someone else's post? Usually there is a "quote" button next to the post you want to quote on other forums.

If there is a better place for this topic, please move it there.
If there is another, older topic that covers my type of questions, please point me there (via PM maybe?) and delete this topic.
Thank you and pls don't get mad at me. I've read the FAQ and searched the forum before posting my questions. Honest.

Re: Editing posts, quoting and other forum-related questions

Posted: Sat Sep 26, 2015 6:01 pm
by Silentcook
The "quote" button should be present at the top right of every post. The "edit" button should be present at the top right of your posts, unless they've been editlocked by a mod or admin, but that practically never happens.

I don't know the exact reasons behind your problem, but I've occasionally heard vague similar rumors. It might be because of overzealous antivirus or adblocking software, browser disagreement with the forums software, or just a plain glitch. I advise you to verify that by trying to log in from different computers first. Assuming that's going to work better, see if you can vary your ways to access the forums from the specific computer you usually use.

Re: Editing posts, quoting and other forum-related questions

Posted: Sun Sep 27, 2015 2:47 pm
by erundil
First of all thank you for your quick response.

I tried to test the issue on different configurations. I usually use Firefox, so tried disabling AdBlock, disabling firewall, disabling antivirus (hell, this was a scary step to make), I went as far as trying in Internet Explorer, even though I'd rather not use it, ever. But nothing worked for me. Then I remembered that I could access Katawa Shoujo homepage and Shimmie only via Tor Browser. They won't load any other way, the server simply cannot be found. So I tried the forum in Tor Browser and voila! It works now, both missing buttons are present exactly where you said they should be.

I'm not living in a censorship-heavy country (Poland) and Katawa Shoujo sites are the only ones I've ever had to access via Tor Browser.
So there you have it, I found a workaround, yay. I wonder if anything can be done from your end about the accessability of the page for me.
Especially Shimmie is a pain to use via Tor Browser, since the images are big and it puts a lot of strain on the network, making the site extremely slow. But I guess it's asking for impossible. :|

I also figured that I can see the online status of people in Tor Browser (for example I can see that you're online right now), while this is also not working outside Tor Network masking my IP and redirecting the connection.
Another thing that works differently is the site background - it's a png file in Tor Browser, while in Firefox it's just plain color. I guess it's because the file is hosted in the same place as Shimmie.
I could probably find more examples, but nothing really stand out as of now.

Re: Editing posts, quoting and other forum-related questions

Posted: Sun Sep 27, 2015 8:09 pm
by demonix
Is the server not found message browser based or from cloudflare since if I remember correctly most if not all of the KS sites including the forum are routed through cloudflare

It could also be that your ISPs DNS servers are totally crap and don't have the correct entries (try entering in the address bar to see if that gets you to the KS homepage since that would bypass your DNS servers) to access the KS main page and the shimmie (which is where a majority of the images and buttons are hosted).

Another thing you can do is to open a command prompt and use nslookup to see if you get the correct responses from your ISPs DNS server which should be the following for the KS main page and the shimmie

Non-authoritative answer:

Non-authoritative answer:

If you don't get those responses back then it is likely that your ISPs DNS servers don't have the correct information and if you go into your router setting and change the first DNS server (after taking a note of the IP address listed) to which would mean that your getting your DNS information from your ISP and googles public DNS servers and see if that makes any difference in accessing without using the tor browser.

Re: Editing posts, quoting and other forum-related questions

Posted: Sun Sep 27, 2015 9:15 pm
by erundil
I figured that those edit and quote buttons are there, but they are invisible, since their images don't load.

"Server not found" errors I get on both Katawa Shoujo homepage and Shimmie are browser-based. ... _42_61.png

Trying the IP directly leads to another "site not found" errors, *not* browser-based this time.
homepage: ... _53_61.png
shimmie (both adresses yield the same error): ... _07_54.png

Results from nslookup are correct for homepage address and almost correct for Shimmie's longer adress, except it doesn't return the Alias.
When trying to look up the ip adresses or Shimmie's alias, the results are weird... well, no need to describe it, there is a screenshot. ... _39_27.png
Some of the text on the screenshot is in Polish, so let me translate fast:
Serwer = Server
Nazwa = Name
Nieautorytatywna odpowiedź = Non-authoritative answer
nie może odnaleźć = cannot find / cannot locate / unable to find / unable to locate / was unable to find/locate (can't really guess what the english version would say)

I haven't tried changing the router settings, since you said "if you don't get those responses" and some of them were correct (yet I can access none of those 2 pages). So I wasn't sure if I should.

I'm aware that all this is (most probably) my, or rather my ISP's fault, so thank you for going out of your way to help me.
I checked and I also can't access Oekaki (whatever that is), having the same browser-based error as for Shimmie and homepage, but I can access the Dev Blog just fine (although there may be some images not loading that I haven't noticed, just like on this forum - some background, buttons maybe).

I decided to mess with my router and change the default DNS server to
Everything works like a charm now. Thanks a lot guys. You are awesome.
And my ISP is going to have a very bad day today. It's not that big of a company, so I'm going to unload my frustration on the owner himself. :evil:

Btw: even after I got this thing working, direct IP access to the sites is still impossible for me. I think it's impossible for everyone really.

Re: Editing posts, quoting and other forum-related questions

Posted: Mon Sep 28, 2015 8:05 pm
by demonix
It did look like that you had some DNS problems from looking at those nslookup results since it couldn't get any information on the shimmie, but it looks like there was some routeing issues as well since you could get a record from the main KS site but you couldn't access it unless you used the tor browser since the traffic takes a different route which would be the same when you change DNS servers since it would send traffic down different routes (as demonstrated by a recent routing and partial DNS failure caused by the already mentioned routing failure where even changing to other DNS servers made little difference since some traffic that went through where the fault was located went down a different route to its destination, but others stopped working since they now went down the route they didn't go down before).

And as for the IP address giving a dreamhost site not found message might be because the site isn't hosted on a dedicated server and the IP address shown in the nslookup report doesn't match what a whois check shows, but I'm not an expert in these things.