Server Move + Forum Software Upgrade

A forum for general discussion of the game: Open to all punters
User avatar
PyTom
Programming/Tech
Posts: 86
Joined: Mon Apr 23, 2007 10:51 pm
Contact:

Server Move + Forum Software Upgrade

Post by PyTom » Mon Apr 02, 2012 9:58 am

I've moved the Katawa Shoujo forums to a new server. Our new server is much faster than the older one, and costs me less per month to run (at least in the long run).

As part of the move, I've upgraded the software that runs the forums to the latest version of phpBB. While this change shouldn't affect anything important, it's possible that some problems may occur as part of the move. If you see anything amiss, please post it here and I'll take care of it.
Ren'Py Creator - KS Forum Host

User avatar
danyo
Posts: 72
Joined: Mon Jan 23, 2012 2:06 pm

Re: Server Move + Forum Software Upgrade

Post by danyo » Tue Apr 03, 2012 4:13 pm

I just noticed this topic, I don't know about others, but I noticed a drastic speed increase for loading the page, this would explain why! If it's cheaper, then I guess you got a great deal :)

Ps.: thanks for keeping this forum etc up, kinda suprising no one else posted here yet :o

User avatar
gRaViJa
Posts: 298
Joined: Sun Feb 05, 2012 5:02 pm

Re: Server Move + Forum Software Upgrade

Post by gRaViJa » Tue Apr 03, 2012 4:43 pm

I thought this topic was closed for replies =|

Thumbs up for the staff!
Emi's Couch to 5k
Completed!
6k personal record: 29m07
5k personal record: 27m48
1 mile personal record: 6m59

100 push-up challenge
Week 7: 25/25/25/25

User avatar
Paddy
Posts: 251
Joined: Wed Mar 14, 2012 10:47 am
Location: In wheat fields, which must be placed on the valley floor.

Re: Server Move + Forum Software Upgrade

Post by Paddy » Tue Apr 03, 2012 4:45 pm

Thanks for the improvement. I don't know if it is related to the change, but when I try to send PMs, my connection keeps resetting and I sometimes have trouble sending replies.
I'm weary of the railway,
Poor Paddy works on the railway.

Блажен муж, иже не иде на совет нечестивых.
Blessed is the man, who walks not in the counsel of the wicked. (Psalm 1:1)
Got questions about God, Christianity, or the Catholic Church?

User avatar
PyTom
Programming/Tech
Posts: 86
Joined: Mon Apr 23, 2007 10:51 pm
Contact:

Re: Server Move + Forum Software Upgrade

Post by PyTom » Tue Apr 03, 2012 4:51 pm

Paddy wrote:Thanks for the improvement. I don't know if it is related to the change, but when I try to send PMs, my connection keeps resetting and I sometimes have trouble sending replies.
I don't think that would be related to the upgrades. You don't connect directly to the server, but instead to the cloudflare proxy network. If the server dropped the connection, you should see a cloudflare error message, rather than just a drop.
Ren'Py Creator - KS Forum Host

User avatar
newnar
Posts: 430
Joined: Wed Jan 25, 2012 4:46 am
Location: A country that forces me to join the army

Re: Server Move + Forum Software Upgrade

Post by newnar » Tue Apr 03, 2012 9:11 pm

One weird thing to report: The KS icons on my tabs have disappeared recently
I am a guy.
I sometimes talk like Rin Tezuka.
I am in love with Hanako Ikezawa.
NoOne3 wrote:Imagine a male Rin who secretly likes Hanako.
this
YES I AM. DEAL WITH IT.

User avatar
Mirrormn
Posts: 439
Joined: Fri Mar 02, 2012 12:49 am

Re: Server Move + Forum Software Upgrade

Post by Mirrormn » Tue Apr 03, 2012 9:30 pm

Since the update, the animation behavior of the icons to the left of thread titles on the main forum indices (i.e., http://ks.renai.us/viewforum.php?f=13) has changed. It used to be that these icons would only animate for threads with unread posts, but now it seems that they animate for any thread that I have ever posted a comment in, regardless of whether there is new activity in that thread or not.

I can't really say whether this is an intended change or not; on the one hand, it seems like the new behavior is able to give more information about the status of threads on the forum, because it incorporates more possible states (white+animated did not seem to be a possible state with the old behavior, whereas now white+animated and red+animated are both possible and have different meanings). On the other hand, I find it highly distracting and don't like it very much :(

Anyway, just thought I would comment about it, since this seems to be the place.

By the way, the submit time for posting new comments in a thread seems to be vastly improved, especially for longer posts. So overall, I'm very appreciative for the upgrade!

Edit: I am also experiencing the same issue as Newnar; my browser is no longer displaying the website's favicon in its tabs.

Edit 2: Actually, the favicon seems to display properly on the main forum indices, but not on specific threads nor while posting responses.
Katawa Shoujo OST Transcriptions and Arrangements: Consolidated list

Katawa Shoujo Music Index and Table of Contents

Game completion: 100% several times over
Favorite route: Rin
Insights on Rin | Insights on Shizune

User avatar
newnar
Posts: 430
Joined: Wed Jan 25, 2012 4:46 am
Location: A country that forces me to join the army

Re: Server Move + Forum Software Upgrade

Post by newnar » Wed Apr 04, 2012 12:54 am

Not sure if it's because I'm using a phone browser to lurk the forums, but the new 'no new posts' thread icon turned into a white circle with blue outline.
I am a guy.
I sometimes talk like Rin Tezuka.
I am in love with Hanako Ikezawa.
NoOne3 wrote:Imagine a male Rin who secretly likes Hanako.
this
YES I AM. DEAL WITH IT.

User avatar
PikKirby
Posts: 50
Joined: Sun Mar 25, 2012 1:22 pm

Re: Server Move + Forum Software Upgrade

Post by PikKirby » Wed Apr 04, 2012 3:43 pm

Yes. Another person vouching with the favicon issue.
ImageImageImageImageImage

User avatar
demonix
Posts: 356
Joined: Mon Feb 20, 2012 7:20 pm

Re: Server Move + Forum Software Upgrade

Post by demonix » Wed Apr 04, 2012 5:37 pm

Mirrormn wrote:Edit 2: Actually, the favicon seems to display properly on the main forum indices, but not on specific threads nor while posting responses.
Actually the favicon doesn't work at all on my end (it's still showing in my bookmarks, but not in the tabs).

User avatar
Mirrormn
Posts: 439
Joined: Fri Mar 02, 2012 12:49 am

Re: Server Move + Forum Software Upgrade

Post by Mirrormn » Wed Apr 04, 2012 5:40 pm

demonix wrote:
Mirrormn wrote:Edit 2: Actually, the favicon seems to display properly on the main forum indices, but not on specific threads nor while posting responses.
Actually the favicon doesn't work at all on my end (it's still showing in my bookmarks, but not in the tabs).
I would speculate that this means it is no longer being provided by the server at all, and is just cached for certain pages by my browser (Chrome).
Katawa Shoujo OST Transcriptions and Arrangements: Consolidated list

Katawa Shoujo Music Index and Table of Contents

Game completion: 100% several times over
Favorite route: Rin
Insights on Rin | Insights on Shizune

User avatar
demonix
Posts: 356
Joined: Mon Feb 20, 2012 7:20 pm

Re: Server Move + Forum Software Upgrade

Post by demonix » Wed Apr 04, 2012 5:48 pm

Mirrormn wrote:
demonix wrote: Actually the favicon doesn't work at all on my end (it's still showing in my bookmarks, but not in the tabs).
I would speculate that this means it is no longer being provided by the server at all, and is just cached for certain pages by my browser (Chrome).
And I clear out the cache in waterfox (64-bit version of firefox) every night before I close it which would explain a lot.

Dawnstorm
Posts: 153
Joined: Tue Mar 06, 2012 2:34 am

Re: Server Move + Forum Software Upgrade

Post by Dawnstorm » Wed Apr 04, 2012 6:48 pm

Mirrormn wrote:Since the update, the animation behavior of the icons to the left of thread titles on the main forum indices (i.e., http://ks.renai.us/viewforum.php?f=13) has changed. It used to be that these icons would only animate for threads with unread posts, but now it seems that they animate for any thread that I have ever posted a comment in, regardless of whether there is new activity in that thread or not.
Movement tends to make me nervous, so I've always ignored/tied to ignore the animation. Thus, I don't know what it was like before. Now, however, animation seems to signify a "hot topic", which seems to be any topic that exceeds a certain amount of posts (I'm not sure whether animation starts at 20 or 21, but the cutoff point seems to be around that value).

Silentcook
Carelessly Cooking You
Posts: 2529
Joined: Thu Mar 06, 2008 8:22 am
Location: Imola, Italy

Re: Server Move + Forum Software Upgrade

Post by Silentcook » Thu Apr 05, 2012 2:25 pm

While it's possible to access and browse the members list by moving through its pages, trying to use the alphabetical links results in a 404 message for me.
Shattering your dreams since '94.

Image

User avatar
megiddo
Posts: 72
Joined: Fri Mar 23, 2012 5:22 pm

Re: Server Move + Forum Software Upgrade

Post by megiddo » Thu Apr 05, 2012 3:03 pm

Silentcook wrote:While it's possible to access and browse the members list by moving through its pages, trying to use the alphabetical links results in a 404 message for me.
Replace the & in the url with a ?, like so:
http://ks.renai.us/memberlist.php?first ... memberlist

Post Reply